ASA-202205-2 log raw

[ASA-202205-2] git: arbitrary command execution
Arch Linux Security Advisory ASA-202205-2 ========================================= Severity: Medium Date : 2022-05-16 CVE-ID : CVE-2022-24765 Package : git Type : arbitrary command execution Remote : No Link : https://security.archlinux.org/AVG-2679 Summary ======= The package git before version 2.35.3-1 is vulnerable to arbitrary command execution. Resolution ========== Upgrade to 2.35.3-1. # pacman -Syu "git>=2.35.3-1" The problem has been fixed upstream in version 2.35.3. Workaround ========== None. Description =========== A vulnerability was found in Git. This flaw occurs due to Git not checking the ownership of directories in a local multi-user system when running commands specified in the local repository configuration. This allows the owner of the repository to cause arbitrary commands to be executed by other users who access the repository. Impact ====== References ========== https://lore.kernel.org/git/xmqqv8veb5i6.fsf@gitster.g/ https://security.archlinux.org/CVE-2022-24765