ASA-201610-17 generated external raw

[ASA-201610-17] ocaml: information disclosure
Arch Linux Security Advisory ASA-201610-17 ========================================== Severity: Medium Date : 2016-10-24 CVE-ID : CVE-2015-8869 Package : ocaml Type : information disclosure Remote : Yes Link : https://wiki.archlinux.org/index.php/CVE Summary ======= The package ocaml before version 4.03.0-1 is vulnerable to information disclosure. Resolution ========== Upgrade to 4.03.0-1. # pacman -Syu "ocaml>=4.03.0-1" The problem has been fixed upstream in version 4.03.0. Workaround ========== None. Description =========== OCaml versions 4.02.3 and earlier have a runtime bug that, on 64-bit platforms, causes sizes arguments to an internal memmove call to be sign-extended from 32 to 64-bits before being passed to the memmove function. This leads arguments between 2GiB and 4GiB to be interpreted as larger than they are (specifically, a bit below 2^64), causing a buffer overflow. Arguments between 4GiB and 6GiB are interpreted as 4GiB smaller than they should be, causing a possible information leak. Impact ====== A remote attacker is able to access sensitive information or crash the application. References ========== http://www.openwall.com/lists/oss-security/2016/04/29/6 https://access.redhat.com/security/cve/CVE-2015-8869