ASA-201612-8 generated external raw

[ASA-201612-8] linux-zen: privilege escalation
Arch Linux Security Advisory ASA-201612-8 ========================================= Severity: High Date : 2016-12-07 CVE-ID : CVE-2016-8655 Package : linux-zen Type : privilege escalation Remote : No Link : https://wiki.archlinux.org/index.php/CVE Summary ======= The package linux-zen before version 4.8.12-2 is vulnerable to privilege escalation. Resolution ========== Upgrade to 4.8.12-2. # pacman -Syu "linux-zen>=4.8.12-2" The problem has been fixed upstream but no release is available yet. Workaround ========== None. Description =========== A race condition issue leading to a use-after-free flaw was found in the way the raw packet sockets implementation in the Linux kernel networking subsystem handled synchronization while creating the TPACKET_V3 ring buffer. A local user able to open a raw packet socket (requires the CAP_NET_RAW capability) could use this flaw to elevate their privileges on the system. Impact ====== A local attacker with CAP_NET_RAW capabilities is able to crash the system or run arbitrary code with administrative privileges. References ========== https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=84ac7260236a49c79eede91617700174c2c19b0c http://seclists.org/oss-sec/2016/q4/607 https://access.redhat.com/security/cve/CVE-2016-8655