ASA-201701-14 generated external raw

[ASA-201701-14] irssi: multiple issues
Arch Linux Security Advisory ASA-201701-14 ========================================== Severity: High Date : 2017-01-11 CVE-ID : CVE-2017-5193 CVE-2017-5194 CVE-2017-5195 CVE-2017-5196 Package : irssi Type : multiple issues Remote : Yes Link : https://security.archlinux.org/AVG-127 Summary ======= The package irssi before version 0.8.21-1 is vulnerable to multiple issues including arbitrary code execution and denial of service. Resolution ========== Upgrade to 0.8.21-1. # pacman -Syu "irssi>=0.8.21-1" The problems have been fixed upstream in version 0.8.21. Workaround ========== None. Description =========== - CVE-2017-5193 (denial of service) A NULL pointer dereference has been discovered in the nickcmp function leading to application crash. - CVE-2017-5194 (arbitrary code execution) A use after free vulnerability has been discovered when receiving an invalid nick message potentially leading to arbitrary code execution. - CVE-2017-5195 (denial of service) An out of bounds read has been discovered in certain incomplete control codes leading to application crash. - CVE-2017-5196 (denial of service) An out of bounds read has been discovered in certain incomplete character sequences leading to application crash. Impact ====== A remote attacker is able to crash the application or execute arbitrary code on the affected host. References ========== https://irssi.org/security/irssi_sa_2017_01.txt http://www.openwall.com/lists/oss-security/2017/01/05/2 https://github.com/irssi/irssi/commit/6c6c42e3d1b49d90aacc0b67f8540471cae02a1d https://security.archlinux.org/CVE-2017-5193 https://security.archlinux.org/CVE-2017-5194 https://security.archlinux.org/CVE-2017-5195 https://security.archlinux.org/CVE-2017-5196