ASA-201701-19 generated external raw

[ASA-201701-19] docker: privilege escalation
Arch Linux Security Advisory ASA-201701-19 ========================================== Severity: High Date : 2017-01-13 CVE-ID : CVE-2016-9962 Package : docker Type : privilege escalation Remote : No Link : https://security.archlinux.org/AVG-133 Summary ======= The package docker before version 1:1.12.6-1 is vulnerable to privilege escalation. Resolution ========== Upgrade to 1:1.12.6-1. # pacman -Syu "docker>=1:1.12.6-1" The problem has been fixed upstream in version 1.12.6. Workaround ========== None. Description =========== The runc component used by `docker exec` feature of docker allowed additional container processes via to be ptraced by the pid 1 of the container. This allows the main processes of the container, if running as root, to gain low-level access to these new processes during initialization. An attacker can, depending on the nature of the incoming process, leverage this to elevate access to the host. This ranges from accessing host content through the file descriptors of the incoming process to, potentially, a complete container escape by leveraging memory access or syscall interception. Impact ====== A local unprivileged attacker when running as root inside a docker container is able to access the host filesystem leading to privilege escalation. References ========== https://bugs.archlinux.org/task/52493 https://github.com/opencontainers/runc/commit/50a19c6ff828c58e5dab13830bd3dacde268afe5 https://bugzilla.suse.com/show_bug.cgi?id=1012568 https://github.com/docker/docker/compare/v1.12.5...v1.12.6 https://www.mail-archive.com/fulldisclosure@seclists.org/msg04165.html https://security.archlinux.org/CVE-2016-9962