ASA-201701-28 log generated external raw

[ASA-201701-28] php: multiple issues
Arch Linux Security Advisory ASA-201701-28 ========================================== Severity: High Date : 2017-01-19 CVE-ID : CVE-2016-9935 CVE-2016-9936 CVE-2017-5340 Package : php Type : multiple issues Remote : Yes Link : Summary ======= The package php before version 7.1.1-0 is vulnerable to multiple issues including arbitrary code execution and denial of service. Resolution ========== Upgrade to 7.1.1-0. # pacman -Syu "php>=7.1.1-0" The problems have been fixed upstream in version 7.1.1. Workaround ========== None. Description =========== - CVE-2016-9935 (denial of service) The php_wddx_push_element function in ext/wddx/wddx.c in PHP before 5.6.29 and 7.x before 7.0.14 allows remote attackers to cause a denial of service (out-of-bounds read and memory corruption) or possibly have unspecified other impact via an empty boolean element in a wddxPacket XML document. - CVE-2016-9936 (arbitrary code execution) The unserialize implementation in ext/standard/var.c in PHP 7.x before 7.0.14 allows remote attackers to cause a denial of service (use-after- free) or possibly execute arbitrary code via crafted serialized data. - CVE-2017-5340 (arbitrary code execution) It was found that PHP uses uninitialized memory during calls to `unserialize()`. The payload supplied to `unserialize()` may control this uninitialized memory region and thus may be used to trick PHP into operating on faked objects and calling attacker controlled destructor function pointers, effectively allowing arbitrary code execution via specially crafted serialized data. Impact ====== A remote attacker is able to use specially crafted input to perform a denial of service attack or execute arbitrary code on the affected host. References ==========