ASA-201702-5 generated external raw

[ASA-201702-5] gst-plugins-bad: multiple issues
Arch Linux Security Advisory ASA-201702-5 ========================================= Severity: Critical Date : 2017-02-03 CVE-ID : CVE-2017-5843 CVE-2017-5848 Package : gst-plugins-bad Type : multiple issues Remote : Yes Link : https://security.archlinux.org/AVG-165 Summary ======= The package gst-plugins-bad before version 1.10.3-1 is vulnerable to multiple issues including arbitrary code execution and denial of service. Resolution ========== Upgrade to 1.10.3-1. # pacman -Syu "gst-plugins-bad>=1.10.3-1" The problems have been fixed upstream in version 1.10.3. Workaround ========== None. Description =========== - CVE-2017-5843 (arbitrary code execution) A double-free issue has been found in gstreamer before 1.10.3, in gst_mxf_demux_update_essence_tracks. - CVE-2017-5848 (denial of service) An out-of-bounds read has been found in gstreamer before 1.10.3, in gst_ps_demux_parse_psm. Impact ====== A remote attacker can crash gstreamer or execute arbitrary code on the affected host via a crafted file. References ========== http://seclists.org/oss-sec/2017/q1/284 https://bugzilla.gnome.org/show_bug.cgi?id=777503 https://bugzilla.gnome.org/show_bug.cgi?id=777957 https://security.archlinux.org/CVE-2017-5843 https://security.archlinux.org/CVE-2017-5848