ASA-201705-13 generated external raw

[ASA-201705-13] kdelibs: privilege escalation
Arch Linux Security Advisory ASA-201705-13 ========================================== Severity: High Date : 2017-05-10 CVE-ID : CVE-2017-8422 Package : kdelibs Type : privilege escalation Remote : No Link : https://security.archlinux.org/AVG-270 Summary ======= The package kdelibs before version 4.14.32-1 is vulnerable to privilege escalation. Resolution ========== Upgrade to 4.14.32-1. # pacman -Syu "kdelibs>=4.14.32-1" The problem has been fixed upstream in version 4.14.32. Workaround ========== None. Description =========== KAuth <= 5.33.0 contains a logic flaw in which the service invoking dbus is not properly checked. This allows spoofing the identity of the caller and with some carefully crafted calls can lead to gaining root from an unprivileged account. Impact ====== A local, unprivileged attacker can escalate privileges to become root on the affected host. References ========== https://commits.kde.org/kdelibs/264e97625abe2e0334f97de17f6ffb52582888ab https://www.kde.org/info/security/advisory-20170510-1.txt http://seclists.org/oss-sec/2017/q2/240 https://commits.kde.org/kauth/df875f725293af53399f5146362eb158b4f9216a https://security.archlinux.org/CVE-2017-8422