ASA-201705-7 generated external raw

[ASA-201705-7] freetype2: arbitrary code execution
Arch Linux Security Advisory ASA-201705-7 ========================================= Severity: High Date : 2017-05-09 CVE-ID : CVE-2017-8105 CVE-2017-8287 Package : freetype2 Type : arbitrary code execution Remote : Yes Link : https://security.archlinux.org/AVG-257 Summary ======= The package freetype2 before version 2.7.1-2 is vulnerable to arbitrary code execution. Resolution ========== Upgrade to 2.7.1-2. # pacman -Syu "freetype2>=2.7.1-2" The problems have been fixed upstream but no release is available yet. Workaround ========== None. Description =========== - CVE-2017-8105 (arbitrary code execution) FreeType 2 <= 2.7.1 has an out-of-bounds write caused by a heap-based buffer overflow related to the t1_decoder_parse_charstrings function in psaux/t1decode.c. - CVE-2017-8287 (arbitrary code execution) FreeType 2 <= 2.7.1 has an out-of-bounds write caused by a heap-based buffer overflow related to the t1_builder_close_contour function in psaux/psobjs.c. Impact ====== A remote attacker can execute arbitrary code on the affected host via a crafted font. References ========== https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=941 https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=935 https://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=f958c48ee431bef8d4d466b40c9cb2d4dbcb7791 https://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=3774fc08b502c3e685afca098b6e8a195aded6a0 https://security.archlinux.org/CVE-2017-8105 https://security.archlinux.org/CVE-2017-8287