ASA-201706-3 generated external raw

[ASA-201706-3] libtasn1: arbitrary code execution
Arch Linux Security Advisory ASA-201706-3 ========================================= Severity: High Date : 2017-06-02 CVE-ID : CVE-2017-6891 Package : libtasn1 Type : arbitrary code execution Remote : Yes Link : https://security.archlinux.org/AVG-285 Summary ======= The package libtasn1 before version 4.11-1 is vulnerable to arbitrary code execution. Resolution ========== Upgrade to 4.11-1. # pacman -Syu "libtasn1>=4.11-1" The problem has been fixed upstream in version 4.11. Workaround ========== None. Description =========== Two errors in the "asn1_find_node()" function (lib/parser_aux.c) within GnuTLS libtasn1 version 4.10 can be exploited to cause a stacked-based buffer overflow by tricking a user into processing a specially crafted assignments file via the e.g. asn1Coding utility. Impact ====== A remote attacker can execute arbitrary code on the affected host by tricking a local user into processing a specially crafted assignments file. References ========== https://git.savannah.gnu.org/gitweb/?p=libtasn1.git;a=commitdiff;h=5520704d075802df25ce4ffccc010ba1641bd484 https://secuniaresearch.flexerasoftware.com/secunia_research/2017-11/ https://security.archlinux.org/CVE-2017-6891