ASA-201706-32 generated external raw

[ASA-201706-32] expat: denial of service
Arch Linux Security Advisory ASA-201706-32 ========================================== Severity: Medium Date : 2017-06-26 CVE-ID : CVE-2016-9063 CVE-2017-9233 Package : expat Type : denial of service Remote : Yes Link : https://security.archlinux.org/AVG-306 Summary ======= The package expat before version 2.2.1-1 is vulnerable to denial of service. Resolution ========== Upgrade to 2.2.1-1. # pacman -Syu "expat>=2.2.1-1" The problems have been fixed upstream in version 2.2.1. Workaround ========== None. Description =========== - CVE-2016-9063 (denial of service) An integer overflow vulnerability has been discovered during the parsing of XML using the Expat library. - CVE-2017-9233 (denial of service) An external entity infinite loop issue has been found in Expat < 2.2.1, leading to a denial of service. Impact ====== An attacker can cause a denial of service in an application using expat by sending a crafted XML payload. References ========== https://www.mozilla.org/en-US/security/advisories/mfsa2016-89/#CVE-2016-9063 https://github.com/libexpat/libexpat/commit/d4f735b88d9932bd5039df2335eefdd0723dbe20 https://libexpat.github.io/doc/cve-2017-9233/ https://security.archlinux.org/CVE-2016-9063 https://security.archlinux.org/CVE-2017-9233