ASA-201707-7 generated external raw

[ASA-201707-7] libdwarf: denial of service
Arch Linux Security Advisory ASA-201707-7 ========================================= Severity: Low Date : 2017-07-11 CVE-ID : CVE-2017-9998 Package : libdwarf Type : denial of service Remote : No Link : https://security.archlinux.org/AVG-332 Summary ======= The package libdwarf before version 20170709-1 is vulnerable to denial of service. Resolution ========== Upgrade to 20170709-1. # pacman -Syu "libdwarf>=20170709-1" The problem has been fixed upstream in version 20170709. Workaround ========== None. Description =========== The _dwarf_decode_s_leb128_chk function in dwarf_leb.c in libdwarf through 2017-06-28 allows attackers to cause a denial of service (Segmentation fault) via a crafted file. Impact ====== An attacker can cause a denial of service by tricking a local user into submitting a crafted file to a program linked against libdwarf. References ========== https://bugzilla.redhat.com/show_bug.cgi?id=1465756 https://security.archlinux.org/CVE-2017-9998