ASA-201710-18 generated external raw

[ASA-201710-18] pcre2: denial of service
Arch Linux Security Advisory ASA-201710-18 ========================================== Severity: Medium Date : 2017-10-12 CVE-ID : CVE-2017-7186 Package : pcre2 Type : denial of service Remote : Yes Link : https://security.archlinux.org/AVG-223 Summary ======= The package pcre2 before version 10.30-1 is vulnerable to denial of service. Resolution ========== Upgrade to 10.30-1. # pacman -Syu "pcre2>=10.30-1" The problem has been fixed upstream in version 10.30. Workaround ========== None. Description =========== libpcre1 in PCRE 8.40 and libpcre2 in PCRE2 10.23 allow remote attackers to cause a denial of service (segmentation violation for read access, and application crash) by triggering an invalid Unicode property lookup. Impact ====== A remote attacker is able to crash the application by triggering an invalid Unicode property lookup. References ========== https://vcs.pcre.org/pcre/code/trunk/pcre_ucd.c?r1=1490&r2=1688&sortby=date https://bugs.exim.org/show_bug.cgi?id=2052 https://blogs.gentoo.org/ago/2017/03/14/libpcre-invalid-memory-read-in-match-pcre_exec-c/ https://vcs.pcre.org/pcre2/code/trunk/src/pcre2_internal.h?r1=600&r2=670&sortby=date https://vcs.pcre.org/pcre2/code/trunk/src/pcre2_ucd.c?r1=316&r2=670&sortby=date https://security.archlinux.org/CVE-2017-7186