ASA-201805-2 generated external raw

[ASA-201805-2] libraw: multiple issues
Arch Linux Security Advisory ASA-201805-2 ========================================= Severity: Critical Date : 2018-05-09 CVE-ID : CVE-2018-10528 CVE-2018-10529 Package : libraw Type : multiple issues Remote : Yes Link : https://security.archlinux.org/AVG-681 Summary ======= The package libraw before version 0.18.10-1 is vulnerable to multiple issues including arbitrary code execution and information disclosure. Resolution ========== Upgrade to 0.18.10-1. # pacman -Syu "libraw>=0.18.10-1" The problems have been fixed upstream in version 0.18.10. Workaround ========== None. Description =========== - CVE-2018-10528 (arbitrary code execution) A stack-based buffer overflow has been found in LibRaw before 0.18.10, in the utf2char() function in libraw_cxx.cpp. - CVE-2018-10529 (information disclosure) An out-of-bounds read has been found in LibRaw before 0.18.10, in the X3F property table list implementation in libraw_x3f.cpp and libraw_cxx.cpp Impact ====== A remote attacker is able to execute arbitrary code or disclose information by providing a specially crafted file. References ========== https://bugs.archlinux.org/task/58393 https://github.com/LibRaw/LibRaw/issues/144 https://github.com/LibRaw/LibRaw/commit/895529fc2f2eb8bc633edd6b04b5b237eb4db564 https://github.com/LibRaw/LibRaw/commit/6f89e5505b1759b788f15cd14d0958b262b82f97 https://github.com/LibRaw/LibRaw/commit/efd8cfabb93fd0396266a7607069901657c082e3 https://github.com/LibRaw/LibRaw/commit/f0c505a3e5d47989a5f69be2d0d4f250af6b1a6c https://github.com/LibRaw/LibRaw/commit/6b08eae24034789b3543a1b66dd6af9c20230029 https://security.archlinux.org/CVE-2018-10528 https://security.archlinux.org/CVE-2018-10529