ASA-201807-13 generated external raw

[ASA-201807-13] networkmanager-vpnc: privilege escalation
Arch Linux Security Advisory ASA-201807-13 ========================================== Severity: High Date : 2018-07-20 CVE-ID : CVE-2018-10900 Package : networkmanager-vpnc Type : privilege escalation Remote : No Link : https://security.archlinux.org/AVG-739 Summary ======= The package networkmanager-vpnc before version 1.2.6-1 is vulnerable to privilege escalation. Resolution ========== Upgrade to 1.2.6-1. # pacman -Syu "networkmanager-vpnc>=1.2.6-1" The problem has been fixed upstream in version 1.2.6. Workaround ========== None. Description =========== When initiating a VPNC connection, Network Manager spawns a new vpnc process and passes the configuration via STDIN. By injecting a \n character into a configuration parameter, an attacker can coerce Network Manager to set the Password helper option to an attacker controlled executable file. Impact ====== A local attacker is able to escalate privileges via a specially crafted configuration file. References ========== https://gitlab.gnome.org/GNOME/NetworkManager-vpnc/commit/07ac18a32b4 https://download.gnome.org/sources/NetworkManager-vpnc/1.2/NetworkManager-vpnc-1.2.6.news https://marc.info/?l=oss-security&m=153207963021874 https://security.archlinux.org/CVE-2018-10900