ASA-201810-2 generated external raw

[ASA-201810-2] ntp: arbitrary code execution
Arch Linux Security Advisory ASA-201810-2 ========================================= Severity: Medium Date : 2018-10-01 CVE-ID : CVE-2018-12327 Package : ntp Type : arbitrary code execution Remote : No Link : https://security.archlinux.org/AVG-723 Summary ======= The package ntp before version 4.2.8.p12-1 is vulnerable to arbitrary code execution. Resolution ========== Upgrade to 4.2.8.p12-1. # pacman -Syu "ntp>=4.2.8.p12-1" The problem has been fixed upstream in version 4.2.8.p12. Workaround ========== None. Description =========== Stack-based buffer overflow in ntpq and ntpdc of NTP version 4.2.8p11 allows an attacker to achieve code execution or escalate to higher privileges via a long string as the argument for an IPv4 or IPv6 command-line parameter. Impact ====== A local attacker is able to execute arbitrary code via specially crafted command line options. References ========== https://gist.github.com/fakhrizulkifli/9b58ed8e0354e8deee50b0eebd1c011f http://bk.ntp.org/ntp-stable/?PAGE=patch&REV=5b3ba863G-42Ac2TFzCy-PZ8vqNfVA https://security.archlinux.org/CVE-2018-12327