ASA-201812-10 generated external raw

[ASA-201812-10] webkit2gtk: arbitrary code execution
Arch Linux Security Advisory ASA-201812-10 ========================================== Severity: Critical Date : 2018-12-14 CVE-ID : CVE-2018-4437 Package : webkit2gtk Type : arbitrary code execution Remote : Yes Link : https://security.archlinux.org/AVG-834 Summary ======= The package webkit2gtk before version 2.22.5-1 is vulnerable to arbitrary code execution. Resolution ========== Upgrade to 2.22.5-1. # pacman -Syu "webkit2gtk>=2.22.5-1" The problem has been fixed upstream in version 2.22.5. Workaround ========== None. Description =========== Multiple memory corruption issues have been found in WebKitGTK+ before 2.22.5, where processing maliciously crafted web content may lead to arbitrary code execution. Impact ====== A remote attacker can execute arbitrary code via crafted web content. References ========== https://webkitgtk.org/security/WSA-2018-0009.html https://webkitgtk.org/security/WSA-2018-0009.html#CVE-2018-4437 https://security.archlinux.org/CVE-2018-4437