ASA-201901-15 generated external raw

[ASA-201901-15] haproxy: denial of service
Arch Linux Security Advisory ASA-201901-15 ========================================== Severity: Medium Date : 2019-01-24 CVE-ID : CVE-2018-20102 CVE-2018-20103 Package : haproxy Type : denial of service Remote : Yes Link : https://security.archlinux.org/AVG-836 Summary ======= The package <a href="/package/haproxy">haproxy</a> before version 1.9.0-1 is vulnerable to denial of service. Resolution ========== Upgrade to 1.9.0-1. # pacman -Syu "haproxy>=1.9.0-1" The problems have been fixed upstream in version 1.9.0. Workaround ========== None. Description =========== - CVE-2018-20102 (denial of service) A stack-based out-of-bounds read has been found in <a href="/package/haproxy">HAProxy</a> before 1.8.15, in the dns_validate_dns_response() function in dns.c, where it can be triggered by a crafted DNS packet. - CVE-2018-20103 (denial of service) A stack-exhaustion issue has been found in <a href="/package/haproxy">HAProxy</a> before 1.8.15, in the dns_read_name() function in dns.c, where an infinite recursion can be triggered via a crafted DNS packet. Impact ====== A remote attacker is able to crash the server with a specially crafted DNS packet. References ========== https://www.mail-archive.com/haproxy@formilux.org/msg32055.html https://git.haproxy.org/?p=haproxy-1.8.git;a=commitdiff;h=2e53fe850be462dab2c1141f044a94d248d68bfe https://git.haproxy.org/?p=haproxy-1.8.git;a=commitdiff;h=12e27845513f87fe2df88e5795d0273f0b992a91 https://git.haproxy.org/?p=haproxy-1.8.git;a=commitdiff;h=2b514b24f71af8ff8c6593636850b9a312a05278 https://security.archlinux.org/CVE-2018-20102 https://security.archlinux.org/CVE-2018-20103