ASA-201906-20 generated external raw

[ASA-201906-20] firefox: sandbox escape
Arch Linux Security Advisory ASA-201906-20 ========================================== Severity: High Date : 2019-06-25 CVE-ID : CVE-2019-11708 Package : firefox Type : sandbox escape Remote : Yes Link : https://security.archlinux.org/AVG-997 Summary ======= The package <a href="/package/firefox">firefox</a> before version 67.0.4-1 is vulnerable to sandbox escape. Resolution ========== Upgrade to 67.0.4-1. # pacman -Syu "firefox>=67.0.4-1" The problem has been fixed upstream in version 67.0.4. Workaround ========== None. Description =========== An issue has been found in <a href="/package/firefox">Firefox</a> before 67.0.4, where an insufficient vetting of parameters passed with the Prompt:Open IPC message between child and parent processes can result in the non-sandboxed parent process opening web content chosen by a compromised child process. When combined with additional vulnerabilities this could result in executing arbitrary code on the user's computer. Impact ====== An attacker could use this vulnerability, combined with another one, to bypass the sandbox and execute arbitrary code on the host. References ========== https://www.mozilla.org/en-US/security/advisories/mfsa2019-19/#CVE-2019-11708 https://bugzilla.mozilla.org/show_bug.cgi?id=1559858 https://security.archlinux.org/CVE-2019-11708