ASA-202106-14 log generated external raw

[ASA-202106-14] ruby-bundler: insufficient validation
Arch Linux Security Advisory ASA-202106-14 ========================================== Severity: Medium Date : 2021-06-01 CVE-ID : CVE-2020-36327 Package : ruby-bundler Type : insufficient validation Remote : Yes Link : Summary ======= The package ruby-bundler before version 2.2.18-1 is vulnerable to insufficient validation. Resolution ========== Upgrade to 2.2.18-1. # pacman -Syu "ruby-bundler>=2.2.18-1" The problem has been fixed upstream in version 2.2.18. Workaround ========== None. Description =========== Bundler 1.16.0 through 2.2.9 and 2.2.11 through 2.2.17 sometimes chooses a dependency source based on the highest gem version number, which means that a rogue gem found at a public source may be chosen, even if the intended choice was a private gem that is a dependency of another private gem that is explicitly depended on by the application. Impact ====== A remote attacker could replace a private gem in a project with a public gem under their control with a higher version number. References ==========