AVG-2220 log

Package webkit2gtk
Status Fixed
Severity High
Type multiple issues
Affected 2.32.2-1
Fixed 2.32.3-1
Current 2.34.2-1 [extra]
Ticket None
Created Sun Jul 25 12:28:53 2021
Issue Severity Remote Type Description
CVE-2021-30799 Medium Yes Arbitrary code execution
A security issue has been found in WebKitGTK and WPE WebKit before 2.32.3. Processing maliciously crafted web content may lead to arbitrary code execution.
CVE-2021-30797 Medium Yes Arbitrary code execution
A security issue has been found in WebKitGTK and WPE WebKit before 2.32.3. Processing maliciously crafted web content may lead to code execution.
CVE-2021-30795 Medium Yes Arbitrary code execution
A security issue has been found in WebKitGTK and WPE WebKit before 2.32.3. Processing maliciously crafted web content may lead to arbitrary code execution.
CVE-2021-30749 Medium Yes Arbitrary code execution
A security issue has been found in WebKitGTK and WPE WebKit before 2.32.3. Processing maliciously crafted web content may lead to arbitrary code execution.
CVE-2021-30744 Medium Yes Cross-site scripting
A security issue has been found in WebKitGTK and WPE WebKit before 2.32.3. Processing maliciously crafted web content may lead to universal cross site scripting.
CVE-2021-30734 Medium Yes Arbitrary code execution
A security issue has been found in WebKitGTK and WPE WebKit before 2.32.3. Processing maliciously crafted web content may lead to arbitrary code execution.
CVE-2021-30720 Medium Yes Access restriction bypass
A security issue has been found in WebKitGTK and WPE WebKit before 2.32.3. A malicious website may be able to access restricted ports on arbitrary servers.
CVE-2021-30689 Medium Yes Cross-site scripting
A security issue has been found in WebKitGTK and WPE WebKit before 2.32.3. Processing maliciously crafted web content may lead to universal cross site scripting.
CVE-2021-30665 High Yes Arbitrary code execution
A security issue has been found in WebKitGTK and WPE WebKit before 2.32.3. Processing maliciously crafted web content may lead to arbitrary code execution....
CVE-2021-30663 Medium Yes Arbitrary code execution
A security issue has been found in WebKitGTK and WPE WebKit before 2.32.3. Processing maliciously crafted web content may lead to arbitrary code execution.
CVE-2021-21779 Medium Yes Information disclosure
A security issue has been found in WebKitGTK and WPE WebKit before 2.32.3. A use-after-free vulnerability exists in the way that WebKit GraphicsContext...
CVE-2021-21775 Medium Yes Information disclosure
A security issue has been found in WebKitGTK and WPE WebKit before 2.32.3. A use-after-free vulnerability exists in the way certain events are processed for...
Date Advisory Package Type
27 Jul 2021 ASA-202107-67 webkit2gtk multiple issues