AVG-2299 log

Package vivaldi
Status Fixed
Severity High
Type arbitrary code execution
Affected 4.1.2369.16-1
Fixed 4.1.2369.21-1
Current 5.3.2679.68-1 [community]
Ticket None
Created Sun Aug 22 11:07:45 2021
Issue Severity Remote Type Description
CVE-2021-30604 High Yes Arbitrary code execution
A use after free security issue has been found in the ANGLE component of the Chromium browser engine before version 92.0.4515.159.
CVE-2021-30603 High Yes Arbitrary code execution
A race security issue has been found in the WebAudio component of the Chromium browser engine before version 92.0.4515.159.
CVE-2021-30602 High Yes Arbitrary code execution
A use after free security issue has been found in the WebRTC component of the Chromium browser engine before version 92.0.4515.159.
CVE-2021-30601 High Yes Arbitrary code execution
A use after free security issue has been found in the Extensions API component of the Chromium browser engine before version 92.0.4515.159.
CVE-2021-30600 High Yes Arbitrary code execution
A use after free security issue has been found in the Printing component of the Chromium browser engine before version 92.0.4515.159.
CVE-2021-30599 High Yes Arbitrary code execution
A type confusion security issue has been found in the V8 component of the Chromium browser engine before version 92.0.4515.159.
CVE-2021-30598 High Yes Arbitrary code execution
A type confusion security issue has been found in the V8 component of the Chromium browser engine before version 92.0.4515.159.
References
https://vivaldi.com/blog/desktop/minor-update-desktop-4-1/
https://vivaldi.com/blog/desktop/minor-update-3-for-desktop-browser-4-1/
Notes
Vivaldi version 4.1.2369.16 is based on Chromium version 92.0.4515.134, Vivaldi version 4.1.2369.21 is based on Chromium version 92.0.4515.159 according to the references.