CVE-2016-9445 log

Source
Severity High
Remote Yes
Type Arbitrary code execution
Description
The vmnc decoder in gst-plugins-bad of the gstreamer code base contains a width * height * depth integer overflow in the allocation of the render buffer inside gst/vmnc/vmncdec.c.
Group Package Affected Fixed Severity Status Ticket
AVG-76 gst-plugins-bad 1.10.0-1 1.10.2-2 High Fixed
Date Advisory Group Package Severity Description
02 Jan 2017 ASA-201701-3 AVG-76 gst-plugins-bad High multiple issues
References
https://scarybeastsecurity.blogspot.de/2016/11/0day-poc-risky-design-decisions-in.html
https://cgit.freedesktop.org/gstreamer/gst-plugins-bad/commit/gst/vmnc/vmncdec.c?id=4cb1bcf1422bbcd79c0f683edb7ee85e3f7a31fe
https://bugzilla.gnome.org/show_bug.cgi?id=774533