CVE-2017-5975

Source
Severity High
Remote Yes
Type Arbitrary code execution
Description
Heap-based buffer overflow in the __zzip_get64 function in fetch.c in zziplib 0.13.62 allows remote attackers to cause a denial of service (crash) via a crafted ZIP file.
Group Package Affected Fixed Severity Status Ticket
AVG-191 zziplib 0.13.62-2 0.13.66-2 High Fixed FS#53133
Date Advisory Group Package Severity Description
12 May 2017 ASA-201705-15 AVG-191 zziplib High multiple issues
References
https://blogs.gentoo.org/ago/2017/02/09/zziplib-heap-based-buffer-overflow-in-__zzip_get64-fetch-c/
https://github.com/gdraheim/zziplib/commit/64e745f8a3604ba1c444febed86b5e142ce03dd7
https://github.com/gdraheim/zziplib/commit/33d6e9c52fcf1a8983896a512033994dc2ca5734