CVE-2019-18183 log

Source
Severity High
Remote Yes
Type Arbitrary command execution
Description
pacman before 5.2 is vulnerable to arbitrary command injection in lib/libalpm/sync.c in the apply_deltas() function. This can be exploited when unsigned databases are used. To exploit the vulnerability, the user must enable the non-default delta feature and retrieve an attacker-controlled crafted database and delta file.
Group Package Affected Fixed Severity Status Ticket
AVG-1049 pacman 5.1.3-1 5.2.0-1 High Fixed
Date Advisory Group Package Severity Description
23 Oct 2019 ASA-201910-13 AVG-1049 pacman High arbitrary command execution
References
https://git.archlinux.org/pacman.git/tree/lib/libalpm/sync.c?h=v5.1.3#n767
https://git.archlinux.org/pacman.git/commit/?id=c0e9be7973be6c81b22fde91516fb8991e7bb07b