CVE-2019-7578

Source
Severity High
Remote Yes
Type Arbitrary code execution
Description
SDL (Simple DirectMedia Layer) through 1.2.15 and 2.x through 2.0.9 has a heap-based buffer over-read in InitIMA_ADPCM in audio/SDL_wave.c.
Group Package Affected Fixed Severity Status Ticket
AVG-891 sdl2 2.0.9-1 2.0.9-2 High Vulnerable
AVG-890 sdl 1.2.15-10 1.2.15-11 High Vulnerable
References
https://bugzilla.libsdl.org/show_bug.cgi?id=4494
https://discourse.libsdl.org/t/vulnerabilities-found-in-libsdl-1-2-15-and-sdl2/25720