CVE-2019-9169

Source
Severity High
Remote No
Type Arbitrary code execution
Description
In the GNU C Library (aka glibc or libc6) through 2.29, proceed_next_node in posix/regexec.c has a heap-based buffer over-read via an attempted case-insensitive regular-expression match.
Group Package Affected Fixed Severity Status Ticket
AVG-855 glibc 2.29-4 High Vulnerable
References
https://sourceware.org/git/gitweb.cgi?p=glibc.git;a=commitdiff;h=583dd860d5b833037175247230a328f0050dbfe9
https://sourceware.org/bugzilla/show_bug.cgi?id=24114
https://debbugs.gnu.org/cgi/bugreport.cgi?bug=34142
https://debbugs.gnu.org/cgi/bugreport.cgi?bug=34140