CVE-2021-27021 log

Source
Severity Medium
Remote Yes
Type Privilege escalation
Description
A flaw was discovered in Puppet DB, this flaw results in an escalation of privileges which allows the user to delete tables via an SQL query. This has been resolved in Puppet DB 6.17.0, 7.4.1, Platform 6.23, 7.7.0 and Puppet Enterprise 2021.2, 2019.8.7.
Group Package Affected Fixed Severity Status Ticket
AVG-2106 puppet5 5.5.22-3 Medium Vulnerable
AVG-2105 puppet 6.22.1-1 6.23.0-1 Medium Fixed
Date Advisory Group Package Severity Type
01 Jul 2021 ASA-202107-8 AVG-2105 puppet Medium privilege escalation
References
https://puppet.com/security/cve/cve-2021-27021/
https://puppet.com/docs/puppetdb/6/release_notes.html#puppetdb-6170
https://tickets.puppetlabs.com/browse/PDB-5138
https://github.com/puppetlabs/puppetdb/commit/c146e624d230f7410fb648d58ae28c0e3cd457a2
https://github.com/puppetlabs/puppetdb/commit/f8dc81678cf347739838e42cc1c426d96406c266
https://github.com/puppetlabs/puppetdb/commit/72bd137511487643a3a6236ad9e72a5dd4a6fadb