ASA-201702-3 generated external raw

[ASA-201702-3] gst-plugins-good: denial of service
Arch Linux Security Advisory ASA-201702-3 ========================================= Severity: Low Date : 2017-02-03 CVE-ID : CVE-2016-10198 CVE-2016-10199 CVE-2017-5840 CVE-2017-5841 CVE-2017-5845 Package : gst-plugins-good Type : denial of service Remote : Yes Link : https://security.archlinux.org/AVG-163 Summary ======= The package gst-plugins-good before version 1.10.3-1 is vulnerable to denial of service. Resolution ========== Upgrade to 1.10.3-1. # pacman -Syu "gst-plugins-good>=1.10.3-1" The problems have been fixed upstream in version 1.10.3. Workaround ========== None. Description =========== - CVE-2016-10198 (denial of service) An invalid memory read flaw has been found in gstreamer before 1.10.3, in gst_aac_parse_sink_setcaps. - CVE-2016-10199 (denial of service) An out of bounds read has been found in gstreamer before 1.10.3, in qtdemux_tag_add_str_full. - CVE-2017-5840 (denial of service) An out-of-bounds read has been found in gstreamer before 1.10.3, in qtdemux_parse_samples. - CVE-2017-5841 (denial of service) An out-of-bounds read has been found in gstreamer before 1.10.3, in gst_avi_demux_parse_ncdt. - CVE-2017-5845 (denial of service) An out-of-bounds read has been found in gstreamer before 1.10.3, in gst_avi_demux_parse_ncdt. Impact ====== A remote attacker can crash gstreamer via a crafted file. References ========== http://seclists.org/oss-sec/2017/q1/284 https://bugzilla.gnome.org/show_bug.cgi?id=775450 https://bugzilla.gnome.org/show_bug.cgi?id=775451 https://bugzilla.gnome.org/show_bug.cgi?id=777469 https://bugzilla.gnome.org/show_bug.cgi?id=777500 https://bugzilla.gnome.org/show_bug.cgi?id=777532 https://security.archlinux.org/CVE-2016-10198 https://security.archlinux.org/CVE-2016-10199 https://security.archlinux.org/CVE-2017-5840 https://security.archlinux.org/CVE-2017-5841 https://security.archlinux.org/CVE-2017-5845