ASA-201704-7 generated external raw

[ASA-201704-7] weechat: denial of service
Arch Linux Security Advisory ASA-201704-7 ========================================= Severity: High Date : 2017-04-23 CVE-ID : CVE-2017-8073 Package : weechat Type : denial of service Remote : Yes Link : https://security.archlinux.org/AVG-253 Summary ======= The package weechat before version 1.7.1-1 is vulnerable to denial of service. Resolution ========== Upgrade to 1.7.1-1. # pacman -Syu "weechat>=1.7.1-1" The problem has been fixed upstream in version 1.7.1. Workaround ========== Use the following workaround for weechat>=1.1: /trigger add irc_dcc_quotes modifier "irc_in_privmsg" "${arguments} \ =~ ^[^ ]+ :${\x01}DCC SEND ${\x22} " "/.*//" Description =========== WeeChat before 1.7.1 allows a remote crash by sending a filename via DCC to the IRC plugin. This occurs in the irc_ctcp_dcc_filename_without_quotes function during quote removal, which results in a buffer overflow. Impact ====== A remote attacker is able to crash the application via a maliciously crafted DCC-request. References ========== https://weechat.org/download/security/ https://github.com/weechat/weechat/commit/2fb346f25f79e412cf0ed314fdf791763c19b70b https://security.archlinux.org/CVE-2017-8073