ASA-201705-17 generated external raw

[ASA-201705-17] lxc: insufficient validation
Arch Linux Security Advisory ASA-201705-17 ========================================== Severity: Low Date : 2017-05-13 CVE-ID : CVE-2017-5985 Package : lxc Type : insufficient validation Remote : No Link : https://security.archlinux.org/AVG-204 Summary ======= The package lxc before version 1:2.0.8-1 is vulnerable to insufficient validation. Resolution ========== Upgrade to 1:2.0.8-1. # pacman -Syu "lxc>=1:2.0.8-1" The problem has been fixed upstream in version 2.0.8. Workaround ========== None. Description =========== This security issue was reported by Jann Horn and has to do with a lack of netns ownership check in lxc-user-nic, which would allow any user with a lxc-usernet allocation to create network interfaces on the host including choosing the name of that network interface. The created interface wouldn't be UP so is unlikely to be automatically brought up or get an address, but this issue could be used to squat the name of a real system network interface before it appears. Impact ====== A local attacker is able to spoof a new network interface. References ========== https://lists.linuxcontainers.org/pipermail/lxc-users/2017-March/012925.html https://security.archlinux.org/CVE-2017-5985