ASA-201705-24 generated external raw

[ASA-201705-24] postgresql-libs: man-in-the-middle
Arch Linux Security Advisory ASA-201705-24 ========================================== Severity: High Date : 2017-05-30 CVE-ID : CVE-2017-7485 Package : postgresql-libs Type : man-in-the-middle Remote : Yes Link : https://security.archlinux.org/AVG-280 Summary ======= The package postgresql-libs before version 9.6.3-1 is vulnerable to man-in-the-middle. Resolution ========== Upgrade to 9.6.3-1. # pacman -Syu "postgresql-libs>=9.6.3-1" The problem has been fixed upstream in version 9.6.3. Workaround ========== None. Description =========== A security issue has been found in the libpq component of PostgreSQL < 9.6.3, where the PGREQUIRESSL was no longer enforcing a SSL/TLS connection to a PostgreSQL server. An active Man-in-the-Middle attacker could use this flaw to strip the SSL/TLS protection from a connection between a client and a server. Impact ====== A remote attacker in position of man-in-the-middle can intercept and alter every communication between a vulnerable client and a server. References ========== https://www.postgresql.org/about/news/1746/ https://security.archlinux.org/CVE-2017-7485