ASA-201804-1 generated external raw

[ASA-201804-1] drupal: arbitrary code execution
Arch Linux Security Advisory ASA-201804-1 ========================================= Severity: Critical Date : 2018-04-01 CVE-ID : CVE-2018-7600 Package : drupal Type : arbitrary code execution Remote : Yes Link : https://security.archlinux.org/AVG-665 Summary ======= The package drupal before version 8.5.1-1 is vulnerable to arbitrary code execution. Resolution ========== Upgrade to 8.5.1-1. # pacman -Syu "drupal>=8.5.1-1" The problem has been fixed upstream in version 8.5.1. Workaround ========== None. Description =========== A remote code execution vulnerability exists within multiple subsystems of Drupal 7.x and 8.x. This potentially allows attackers to exploit multiple attack vectors on a Drupal site, which could result in the site being completely compromised. Impact ====== A remote attacker is able to execute arbitrary code by performing a specially crafted request. References ========== https://www.drupal.org/sa-core-2018-002 https://www.tenable.com/blog/critical-drupal-core-vulnerability-what-you-need-to-know https://github.com/drupal/drupal/commit/5ac8738fa69df34a0635f0907d661b509ff9a28f https://security.archlinux.org/CVE-2018-7600