Arch Linux Security Advisory ASA-201804-4
Date : 2018-04-04
CVE-ID : CVE-2017-15710 CVE-2017-15715 CVE-2018-1283 CVE-2018-1301
CVE-2018-1302 CVE-2018-1303 CVE-2018-1312
Package : apache
Type : multiple issues
Remote : Yes
Link : https://security.archlinux.org/AVG-664
The package apache
before version 2.4.33-1 is vulnerable to multiple
issues including session hijacking, access restriction bypass, content
spoofing and denial of service.
Upgrade to 2.4.33-1.
# pacman -Syu "apache>=2.4.33-1"
The problems have been fixed upstream in version 2.4.33.
(denial of service)
httpd 2.0.23 to 2.0.65, 2.2.0 to 2.2.34, and 2.4.0 to 2.4.29,
mod_authnz_ldap, if configured with AuthLDAPCharsetConfig, uses the
Accept-Language header value to lookup the right charset encoding when
verifying the user's credentials. If the header value is not present in
the charset conversion table, a fallback mechanism is used to truncate
it to a two characters value to allow a quick retry (for example, 'en-
US' is truncated to 'en'). A header value of less than two characters
forces an out of bound write of one NUL byte to a memory location that
is not part of the string. In the worst case, quite unlikely, the
process would crash which could be used as a Denial of Service attack.
In the more likely case, this memory is already reserved for future use
and the issue has no effect at all.
(access restriction bypass)
httpd 2.4.0 before 2.4.30, the expression specified in
could match '$' to a newline character in a malicious
filename, rather than matching only the end of the filename. This could
be exploited in environments where uploads of some files are externally
blocked, but only by matching the trailing portion of the filename.
- CVE-2018-1283 (session hijacking)
In Apache httpd 2.2.0 before 2.4.30, when mod_session is configured to
forward its session data to CGI applications (SessionEnv on, not the
default), a remote user may influence their content by using a
"Session" header. This comes from the "HTTP_SESSION" variable name used
by mod_session to forward its data to CGIs, since the prefix "HTTP_" is
also used by the Apache HTTP Server to pass HTTP header fields, per CGI
- CVE-2018-1301 (denial of service)
A specially crafted request could have crashed the Apache HTTP Server
prior to version 2.4.30, due to an out of bound access after a size
limit is reached by reading the HTTP header. This vulnerability is
considered very hard if not impossible to trigger in non-debug mode
(both log and build level), so it is classified as low risk for common
- CVE-2018-1302 (denial of service)
When an HTTP/2 stream was destroyed after being handled, the Apache
HTTP Server prior to version 2.4.30 could have written a NULL pointer
potentially to an already freed memory. The memory pools maintained by
the server make this vulnerability hard to trigger in usual
configurations, the reporter and the team could not reproduce it
outside debug builds, so it is classified as low risk.
- CVE-2018-1303 (denial of service)
A specially crafted HTTP request header could have crashed the Apache
HTTP Server prior to version 2.4.30 due to an out of bound read while
preparing data to be cached in shared memory. It could be used as a
Denial of Service attack against users of mod_cache_socache.
- CVE-2018-1312 (content spoofing)
In Apache httpd 2.2.0 before 2.4.30, when generating an HTTP Digest
authentication challenge, the nonce sent to prevent reply attacks was
not correctly generated using a pseudo-random seed. In a cluster of
servers using a common Digest authentication configuration, HTTP
requests could be replayed across servers by an attacker without
A remote attacker is able to crash a server, hijack a user session,
upload arbitrary files or spoof requests by providing a crafted