ASA-201805-9 generated external raw

[ASA-201805-9] webkit2gtk: arbitrary code execution
Arch Linux Security Advisory ASA-201805-9 ========================================= Severity: Critical Date : 2018-05-13 CVE-ID : CVE-2018-4200 Package : webkit2gtk Type : arbitrary code execution Remote : Yes Link : https://security.archlinux.org/AVG-692 Summary ======= The package webkit2gtk before version 2.20.2-1 is vulnerable to arbitrary code execution. Resolution ========== Upgrade to 2.20.2-1. # pacman -Syu "webkit2gtk>=2.20.2-1" The problem has been fixed upstream in version 2.20.2. Workaround ========== None. Description =========== A memory corruption issue has been found in webkitgtk < 2.20.2, where processing maliciously crafted web content may lead to arbitrary code execution. Impact ====== A remote attacker can execute arbitrary code on the affected host via a specially crafted web content. References ========== https://webkitgtk.org/security/WSA-2018-0004.html#CVE-2018-4200 https://security.archlinux.org/CVE-2018-4200