ASA-201811-20 generated external raw

[ASA-201811-20] webkit2gtk: arbitrary code execution
Arch Linux Security Advisory ASA-201811-20 ========================================== Severity: Critical Date : 2018-11-22 CVE-ID : CVE-2018-4372 Package : webkit2gtk Type : arbitrary code execution Remote : Yes Link : https://security.archlinux.org/AVG-819 Summary ======= The package webkit2gtk before version 2.22.4-1 is vulnerable to arbitrary code execution. Resolution ========== Upgrade to 2.22.4-1. # pacman -Syu "webkit2gtk>=2.22.4-1" The problem has been fixed upstream in version 2.22.4. Workaround ========== None. Description =========== Multiple memory corruption issues have been found in WebKitGTK+ versions prior to 2.22.4, possibly leading to arbitrary code execution while parsing crafted web content. Impact ====== A remote attacker can execute arbitrary code on the affected host via a crafted web content. References ========== https://webkitgtk.org/security/WSA-2018-0008.html https://webkitgtk.org/security/WSA-2018-0008.html#CVE-2018-4372 https://security.archlinux.org/CVE-2018-4372