ASA-201901-8 generated external raw

[ASA-201901-8] irssi: denial of service
Arch Linux Security Advisory ASA-201901-8 ========================================= Severity: Low Date : 2019-01-11 CVE-ID : CVE-2019-5882 Package : irssi Type : denial of service Remote : Yes Link : https://security.archlinux.org/AVG-847 Summary ======= The package irssi before version 1.1.2-1 is vulnerable to denial of service. Resolution ========== Upgrade to 1.1.2-1. # pacman -Syu "irssi>=1.1.2-1" The problem has been fixed upstream in version 1.1.2. Workaround ========== If lines are never hidden (no usage of /window hidelevel), this bug will not trigger. Description =========== A use-after-free vulnerability has been found in irssi before 1.1.2, when hidden lines were expired from the scroll buffer. Impact ====== Irssi can crash when hidden lines are expired from the scroll buffer. References ========== https://marc.info/?l=oss-security&m=154711952322177 https://irssi.org/security/irssi_sa_2019_01.txt https://github.com/irssi/irssi/pull/948 https://security.archlinux.org/CVE-2019-5882