ASA-201904-12 generated external raw

[ASA-201904-12] chromium: multiple issues
Arch Linux Security Advisory ASA-201904-12 ========================================== Severity: Critical Date : 2019-04-24 CVE-ID : CVE-2019-5805 CVE-2019-5806 CVE-2019-5807 CVE-2019-5808 CVE-2019-5809 CVE-2019-5810 CVE-2019-5811 CVE-2019-5813 CVE-2019-5814 CVE-2019-5815 CVE-2019-5818 CVE-2019-5819 CVE-2019-5820 CVE-2019-5821 CVE-2019-5822 CVE-2019-5823 Package : chromium Type : multiple issues Remote : Yes Link : https://security.archlinux.org/AVG-952 Summary ======= The package <a href="/package/chromium">chromium</a> before version 74.0.3729.108-1 is vulnerable to multiple issues including arbitrary code execution, access restriction bypass, information disclosure and insufficient validation. Resolution ========== Upgrade to 74.0.3729.108-1. # pacman -Syu "chromium>=74.0.3729.108-1" The problems have been fixed upstream in version 74.0.3729.108. Workaround ========== None. Description =========== - CVE-2019-5805 (arbitrary code execution) A use-after-free vulnerability has been found in the PDFium component of the <a href="/package/chromium">chromium</a> browser before 74.0.3729.108. - CVE-2019-5806 (arbitrary code execution) An integer overflow vulnerability has been found in the Andle component of the <a href="/package/chromium">chromium</a> browser before 74.0.3729.108. - CVE-2019-5807 (arbitrary code execution) A memory corruption vulnerability has been found in the V8 component of the <a href="/package/chromium">chromium</a> browser before 74.0.3729.108. - CVE-2019-5808 (arbitrary code execution) A use-after-free vulnerability has been found in the Blink component of the <a href="/package/chromium">chromium</a> browser before 74.0.3729.108. - CVE-2019-5809 (arbitrary code execution) A use-after-free vulnerability has been found in the Blink component of the <a href="/package/chromium">chromium</a> browser before 74.0.3729.108. - CVE-2019-5810 (information disclosure) A user information disclosure vulnerability has been found in the Autofill component of the <a href="/package/chromium">chromium</a> browser before 74.0.3729.108. - CVE-2019-5811 (access restriction bypass) A CORS bypass vulnerability has been found in the Blink component of the <a href="/package/chromium">chromium</a> browser before 74.0.3729.108. - CVE-2019-5813 (information disclosure) An out-of-bounds read vulnerability has been found in the V8 component of the <a href="/package/chromium">chromium</a> browser before 74.0.3729.108. - CVE-2019-5814 (access restriction bypass) A CORS bypass vulnerability has been found in the Blink component of the <a href="/package/chromium">chromium</a> browser before 74.0.3729.108. - CVE-2019-5815 (arbitrary code execution) A heap-based buffer overflow vulnerability has been found in the Blink component of the <a href="/package/chromium">chromium</a> browser before 74.0.3729.108. - CVE-2019-5818 (information disclosure) An uninitialized value vulnerability has been found in the media reader component of the <a href="/package/chromium">chromium</a> browser before 74.0.3729.108. - CVE-2019-5819 (insufficient validation) An incorrect escaping vulnerability has been found in the developer tools component of the <a href="/package/chromium">chromium</a> browser before 74.0.3729.108. - CVE-2019-5820 (arbitrary code execution) An integer overflow vulnerability has been found in the PDFium component of the <a href="/package/chromium">chromium</a> browser before 74.0.3729.108. - CVE-2019-5821 (arbitrary code execution) An integer overflow vulnerability has been found in the PDFium component of the <a href="/package/chromium">chromium</a> browser before 74.0.3729.108. - CVE-2019-5822 (access restriction bypass) A CORS bypass vulnerability has been found in the download manager component of the <a href="/package/chromium">chromium</a> browser before 74.0.3729.108. - CVE-2019-5823 (access restriction bypass) A forced navigation from service worker vulnerability has been found in the <a href="/package/chromium">chromium</a> browser before 74.0.3729.108. Impact ====== A remote attacker can access sensitive information, bypass security measures and execute arbitrary code on the affected host. References ========== https://chromereleases.googleblog.com/2019/04/stable-channel-update-for-desktop_23.html https://crbug.com/913320 https://crbug.com/943087 https://crbug.com/945644 https://crbug.com/947029 https://crbug.com/941008 https://crbug.com/916838 https://crbug.com/771815 https://crbug.com/942699 https://crbug.com/930057 https://crbug.com/930663 https://crbug.com/929962 https://crbug.com/919356 https://crbug.com/919635 https://crbug.com/919640 https://crbug.com/926105 https://security.archlinux.org/CVE-2019-5805 https://security.archlinux.org/CVE-2019-5806 https://security.archlinux.org/CVE-2019-5807 https://security.archlinux.org/CVE-2019-5808 https://security.archlinux.org/CVE-2019-5809 https://security.archlinux.org/CVE-2019-5810 https://security.archlinux.org/CVE-2019-5811 https://security.archlinux.org/CVE-2019-5813 https://security.archlinux.org/CVE-2019-5814 https://security.archlinux.org/CVE-2019-5815 https://security.archlinux.org/CVE-2019-5818 https://security.archlinux.org/CVE-2019-5819 https://security.archlinux.org/CVE-2019-5820 https://security.archlinux.org/CVE-2019-5821 https://security.archlinux.org/CVE-2019-5822 https://security.archlinux.org/CVE-2019-5823