AVG-1991 log

Package vivaldi
Status Fixed
Severity High
Type multiple issues
Affected 3.8.2259.42-1
Fixed 4.0.2312.24-1
Current 5.0.2497.24-1 [community]
Ticket None
Created Tue May 25 19:49:32 2021
Issue Severity Remote Type Description
CVE-2021-30543 Medium Yes Arbitrary code execution
A use after free security issue has been found in the Tab Strip component of the Chromium browser before version 91.0.4472.77.
CVE-2021-30542 Medium Yes Arbitrary code execution
A use after free security issue has been found in the Tab Strip component of the Chromium browser before version 91.0.4472.77.
CVE-2021-30539 Low Yes Insufficient validation
An insufficient policy enforcement security issue has been found in the content security policy component of the Chromium browser before version 91.0.4472.77.
CVE-2021-30538 Low Yes Insufficient validation
An insufficient policy enforcement security issue has been found in the content security policy component of the Chromium browser before version 91.0.4472.77.
CVE-2021-30537 Low Yes Insufficient validation
An insufficient policy enforcement security issue has been found in the cookies component of the Chromium browser before version 91.0.4472.77.
CVE-2021-30536 Low Yes Information disclosure
An out of bounds read security issue has been found in the V8 component of the Chromium browser before version 91.0.4472.77.
CVE-2021-30535 Medium Yes Arbitrary code execution
A double free security issue has been found in the ICU component of the Chromium browser before version 91.0.4472.77.
CVE-2021-30534 Medium Yes Insufficient validation
An insufficient policy enforcement security issue has been found in the iFrameSandbox component of the Chromium browser before version 91.0.4472.77.
CVE-2021-30533 Medium Yes Insufficient validation
An insufficient policy enforcement security issue has been found in the PopupBlocker component of the Chromium browser before version 91.0.4472.77.
CVE-2021-30532 Medium Yes Insufficient validation
An insufficient policy enforcement security issue has been found in the Content Security Policy component of the Chromium browser before version 91.0.4472.77.
CVE-2021-30531 Medium Yes Insufficient validation
An insufficient policy enforcement security issue has been found in the Content Security Policy component of the Chromium browser before version 91.0.4472.77.
CVE-2021-30530 Medium Yes Information disclosure
An out of bounds memory access security issue has been found in the WebAudio component of the Chromium browser before version 91.0.4472.77.
CVE-2021-30529 Medium Yes Arbitrary code execution
A use after free security issue has been found in the Bookmarks component of the Chromium browser before version 91.0.4472.77.
CVE-2021-30527 High Yes Arbitrary code execution
A use after free security issue has been found in the WebUI component of the Chromium browser before version 91.0.4472.77.
CVE-2021-30526 High Yes Arbitrary code execution
An out of bounds write security issue has been found in the TabStrip component of the Chromium browser before version 91.0.4472.77.
CVE-2021-30525 High Yes Arbitrary code execution
A use after free security issue has been found in the TabGroups component of the Chromium browser before version 91.0.4472.77.
CVE-2021-30524 High Yes Arbitrary code execution
A use after free security issue has been found in the TabStrip component of the Chromium browser before version 91.0.4472.77.
CVE-2021-30523 High Yes Arbitrary code execution
A use after free security issue has been found in the WebRTC component of the Chromium browser before version 91.0.4472.77.
CVE-2021-30522 High Yes Arbitrary code execution
A use after free security issue has been found in the WebAudio component of the Chromium browser before version 91.0.4472.77.
Notes
Vivaldi version 3.8.2259.42 is based on Chromium version 90.0.4430.214, Vivaldi version 4.0.2312.24 is based on Chromium version 91.0.4472.79.