AVG-2364 log

Package gvim, vim
Status Fixed
Severity Medium
Type arbitrary code execution
Affected 8.2.3340-1
Fixed 8.2.3412-1
Current 8.2.3441-1 [extra]
Ticket None
Created Thu Sep 9 12:49:11 2021
Issue Severity Remote Type Description
CVE-2021-3778 Medium Yes Arbitrary code execution
vim before version 8.2.3409 is vulnerable to a heap-based buffer overflow when reading beyond the end of a line with an invalid UTF-8 character.
CVE-2021-3770 Medium No Arbitrary code execution
vim before version 8.2.3402 is vulnerable to a heap-based buffer overflow when using :retab with large value.