AVG-275

Package libytnef
Status Fixed
Severity High
Type arbitrary code execution
Affected 1.9.2-1
Fixed 1.9.2-2
Current 1.9.3+7+g24fe30e-1 [extra]
Ticket None
Created Thu May 18 13:30:28 2017
Issue Severity Remote Type Description
CVE-2017-9058 High Yes Arbitrary code execution
A heap-buffer-overflow vulnerability has been found in the libytnef in the lib/ytnef.c module.
Date Advisory Package Description
14 Aug 2017 ASA-201708-10 libytnef arbitrary code execution
References
https://github.com/bingosxs/fuzzdata/blob/master/ytnef-1.9/TNEFFreeMapiProps-Invalid-read.tnef?raw=true
Notes
9058 is not fixed as of version 1.9.2: https://github.com/Yeraze/ytnef/blob/master/ChangeLog