CVE-2021-23840 log

Source
Severity Low
Remote Yes
Type Incorrect calculation
Description
Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash.

OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j.

OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j.

Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).
Group Package Affected Fixed Severity Status Ticket
AVG-2317 lib32-openssl-1.0 1.0.2.u-1 High Vulnerable
AVG-1229 openssl-1.0 1.0.2.u-1 High Vulnerable FS#67858
AVG-1611 nodejs-lts-dubnium 10.23.2-1 Low Not affected
AVG-1610 nodejs-lts-erbium 12.20.1-1 Low Not affected
AVG-1609 nodejs-lts-fermium 14.15.4-1 Low Not affected
AVG-1605 nodejs 15.9.0-1 Low Not affected
AVG-1581 openssl 1.1.1.i-2 1.1.1.j-1 Medium Fixed
Date Advisory Group Package Severity Type
27 Feb 2021 ASA-202102-42 AVG-1581 openssl Medium multiple issues
References
https://www.openssl.org/news/secadv/20210216.txt
https://git.openssl.org/gitweb/?p=openssl.git;a=commitdiff;h=6a51b9e1d0cf0bf8515f7201b68fb0a3482b3dc1
https://git.openssl.org/gitweb/?p=openssl.git;a=commitdiff;h=9b1129239f3ebb1d1c98ce9ed41d5c9476c47cb2