zathura-pdf-mupdf

Link package | bugs open | bugs closed | Wiki | GitHub | web search
Description PDF support for Zathura (MuPDF backend) (Supports PDF, ePub, and OpenXPS)
Version 0.3.4-1 [community]

Resolved

Group Affected Fixed Severity Status Ticket
AVG-691 0.3.3-2 0.3.3-3 High Fixed FS#57486
AVG-600 0.3.2-1 0.3.2-2 High Fixed
AVG-476 0.3.1-3 0.3.1-4 High Fixed
Issue Group Severity Remote Type Description
CVE-2018-6544 AVG-691 Medium Yes Denial of service
pdf_load_obj_stm in pdf/pdf-xref.c in Artifex MuPDF 1.12.0 could reference the object stream recursively and therefore run out of error stack, which allows...
CVE-2018-6192 AVG-691 Medium No Denial of service
In Artifex MuPDF 1.12.0, the pdf_read_new_xref function in pdf/pdf- xref.c allows remote attackers to cause a denial of service (segmentation violation and...
CVE-2018-6187 AVG-691 Medium No Denial of service
In Artifex MuPDF 1.12.0, there is a heap-based buffer overflow vulnerability in the do_pdf_save_document function in the pdf/pdf- write.c file. Remote...
CVE-2018-5686 AVG-691 Medium No Denial of service
In MuPDF 1.12.0, there is an infinite loop vulnerability and application hang in the pdf_parse_array function (pdf/pdf-parse.c) because EOF is not...
CVE-2018-1000051 AVG-691 High No Arbitrary code execution
Artifex Mupdf version 1.12.0 contains a use-after-free vulnerability in fz_keep_key_storable that can result in DOS / Possible code execution. This attack...
CVE-2017-17858 AVG-600 High No Arbitrary code execution
Heap-based buffer overflow in the ensure_solid_xref function in pdf/pdf-xref.c in Artifex MuPDF 1.12.0 allows an attacker to potentially execute arbitrary...
CVE-2017-15587 AVG-476 High No Arbitrary code execution
An integer overflow leading to an out-of-bounds wrte has been found in mupdf <= 1.11. The parsing of a crafted PDF might allow an attacker to write...
CVE-2017-14687 AVG-476 High No Arbitrary code execution
Artifex MuPDF 1.11 allows attackers to cause a denial of service or possibly have unspecified other impact via a crafted .xps file. This occurs because of...
CVE-2017-14686 AVG-476 High No Arbitrary code execution
Artifex MuPDF 1.11 allows attackers to execute arbitrary code or cause a denial of service via a crafted .xps file. This occurs because read_zip_dir_imp in...
CVE-2017-14685 AVG-476 High No Arbitrary code execution
Artifex MuPDF 1.11 allows attackers to cause a denial of service or possibly have unspecified other impact via a crafted .xps file. This occurs because...

Advisories

Date Advisory Group Severity Description
16 May 2018 ASA-201805-12 AVG-691 High multiple issues
30 Jan 2018 ASA-201801-31 AVG-600 High arbitrary code execution
01 Nov 2017 ASA-201711-5 AVG-476 High arbitrary code execution