CVE-2018-6187

Source
Severity Medium
Remote No
Type Denial of service
Description
In Artifex MuPDF 1.12.0, there is a heap-based buffer overflow vulnerability in the do_pdf_save_document function in the pdf/pdf-write.c file. Remote attackers could leverage the vulnerability to cause a denial of service via a crafted pdf file.
Group Package Affected Fixed Severity Status Ticket
AVG-691 zathura-pdf-mupdf 0.3.3-2 0.3.3-3 High Fixed FS#57486
AVG-690 llpp 27-1 27-2 High Fixed FS#57486
AVG-689 libmupdf 1.12.0-2 1.13.0-1 High Fixed FS#57486
AVG-688 mupdf-tools 1.12.0-2 1.13.0-1 High Fixed FS#57486
AVG-687 mupdf-gl 1.12.0-2 1.13.0-1 High Fixed FS#57486
AVG-609 mupdf 1.12.0-2 1.13.0-1 High Fixed FS#57486
Date Advisory Group Package Severity Description
10 May 2018 ASA-201805-8 AVG-690 llpp High multiple issues
10 May 2018 ASA-201805-7 AVG-688 mupdf-tools High multiple issues
10 May 2018 ASA-201805-6 AVG-689 libmupdf High multiple issues
10 May 2018 ASA-201805-5 AVG-687 mupdf-gl High multiple issues
09 May 2018 ASA-201805-4 AVG-609 mupdf High multiple issues
16 May 2018 ASA-201805-12 AVG-691 zathura-pdf-mupdf High multiple issues
References
https://bugs.ghostscript.com/show_bug.cgi?id=698908
https://git.ghostscript.com/?p=mupdf.git;a=commitdiff;h=3e30fbb7bf5efd88df431e366492356e7eb969ec