ASA-201902-4 generated external raw

[ASA-201902-4] spice: arbitrary code execution
Arch Linux Security Advisory ASA-201902-4 ========================================= Severity: Critical Date : 2019-02-11 CVE-ID : CVE-2019-3813 Package : spice Type : arbitrary code execution Remote : Yes Link : https://security.archlinux.org/AVG-866 Summary ======= The package spice before version 0.14.0-3 is vulnerable to arbitrary code execution. Resolution ========== Upgrade to 0.14.0-3. # pacman -Syu "spice>=0.14.0-3" The problem has been fixed upstream but no release is available yet. Workaround ========== None. Description =========== Spice, versions 0.5.2 through 0.14.1, are vulnerable to an out-of- bounds read due to an off-by-one error in memslot_get_virt. This may lead to a denial of service, or, in the worst case, code-execution by unauthenticated attackers. Impact ====== A remote, unauthenticated attacker might be able to crash the server, or even execute arbitrary code on said server. References ========== https://bugs.archlinux.org/task/61650 https://gitlab.freedesktop.org/spice/spice/commit/a4a16ac42d2f19a17e36556546aa94d5cd83745f https://access.redhat.com/errata/RHSA-2019:0231 https://security.archlinux.org/CVE-2019-3813