AVG-2472 log

Package gvim, vim
Status Fixed
Severity Low
Type arbitrary code execution
Affected 8.2.3441-1
Fixed 8.2.3582-1
Current 8.2.4106-1 [extra]
Ticket None
Created Sun Oct 17 08:47:10 2021
Issue Severity Remote Type Description
CVE-2021-3928 Low No Arbitrary code execution
Vim before version 8.2.3582 is vulnerable to a heap-based buffer overflow through reading uninitialized memory when giving spell suggestions.
CVE-2021-3927 Low No Arbitrary code execution
Vim before version 8.2.3581 is vulnerable to a heap-based buffer overflow when reading a character past the end of line.
CVE-2021-3903 Low No Arbitrary code execution
Vim before version 8.2.3564 is vulnerable to a heap-based buffer overflow when scrolling without a valid screen.
CVE-2021-3875 Low No Arbitrary code execution
Vim before version 8.2.3489 is vulnerable to a heap-based buffer overflow after a search with range.
CVE-2021-3872 Low No Arbitrary code execution
Vim before version 8.2.3487 is vulnerable to a heap-based buffer overflow if a Vim buffer name is very long.