AVG-2572 log

Package gvim, vim
Status Vulnerable
Severity Low
Type arbitrary code execution
Affected 8.2.3582-1
Fixed Unknown
Current 8.2.3582-1 [extra]
Ticket Create
Created Fri Nov 19 13:17:41 2021
Issue Severity Remote Type Description
CVE-2021-4019 Low No Arbitrary code execution
Vim before version 8.2.3669 is vulnerable to a heap-based buffer overflow when using a long help argument.
CVE-2021-3984 Low No Arbitrary code execution
Vim before version 8.2.3625 is vulnerable to a heap-based buffer overflow when C-indenting.
CVE-2021-3974 Low No Arbitrary code execution
Vim before version 8.2.3612 is vulnerable to a use after free through using freed memory with regexp using a mark.
CVE-2021-3973 Low No Arbitrary code execution
Vim before version 8.2.3611 is vulnerable to a heap-based buffer overflow when using CTRL-W f without finding a file name.
CVE-2021-3968 Low No Arbitrary code execution
Vim before version 8.2.3610 is vulnerable to a heap-based buffer overflow when ModeChanged is triggered too early.